skout-blog

Cybersecurity Threat Advisory 0030-22: Zyxel Firewall vulnerability: Unauthenticated Remote Command Injection

Threat Update

Zyxel’s ATP, VPN, and USG FLEX series business firewalls are affected by a Remote Code Execution (RCE) vulnerability that allows unauthenticated malicious attackers to execute arbitrary commands on the affected devices. Over 20,800 devices have been affected by this vulnerability, with many of which are prevalent in France and Italy. Barracuda MSP recommends applying the latest patches to these firewalls to mitigate the vulnerability.

Technical Detail & Additional Information

WHAT IS THE THREAT?

Known as CVE-2022-30525, the vulnerability is exploited through a device’s HTTP interface to gain a reverse shell. The threat actor can then remotely execute commands as the “nobody” user on devices utilizing these firewalls without providing any form of authentication. Once the threat actors are in, they can then move laterally through the network and attempt to gain control of the host operating system to disable the firewall and begin a barrage of additional attacks.

WHY IS IT NOTEWORTHY?

The Common Vulnerability Scoring System (CVSS) for this vulnerability is at a critical value of 9.8. While many affected Zyxel customers are found in France and Italy, these firewalls have been installed on many devices around the globe. The firewalls are advertised for both small and large corporations, therefore creating the opportunity for attackers to execute their attack once they have identified the vulnerable devices, which are publicly accessible.

WHAT IS THE EXPOSURE OR RISK?

This vulnerability can lead the attacker to compromise affected devices and pivot inside the victim’s internal network. The attacker can easily their reach to internal systems that are not exposed to the internet and compromise of proprietary or confidential information related to the victim or any customers that they may serve.

WHAT ARE THE RECOMMENDATIONS?

Barracuda MSP recommends installing the security update released by Zyxel as soon as possible. It is recommended to enable automatic firmware updates and disable WAN access to the administrative web interface of the system. The following Zyxel firewall models are affected:

•          USG FLEX 100, 100W, 200, 500, 700

•          USG20-VPN, USG20W-VPN

•         ATP 100, 200, 500, 700, 800

REFERENCES

For more in-depth information about the recommendations, please visit the following links:

If you have any questions, please contact our Security Operations Center.

Threat Advisory Sign Up